Vous avez besoin d'aide ? Posez votre question sur le forum, il y a aura toujours un membre pour vous conseiller, et vous dépanner. Poser une question.
Participer, encore 266 messages sans réponses
Le forum de Savoir Tout faire, Comment creer une fonction avec une condition nombre ?

La solution au problème n'a pas été trouvée pour l'instant Comment creer une fonction avec une condition nombre ?

Forum-> Bureautique
Poster un nouveau sujetRépondre au sujet
Voir le sujet précédent :: Voir le sujet suivant  
Auteur Message
eolien70

Nouveau membre
Inscrit le: 26 Nov 11
Messages: 1

MessagePosté le: 26 Nov 2011 18:22 
x = nombre defini
j'aimerai creer une fonction pour que le resultat soit :
a<x<b = vrai
alors = x
sinon = a
j avais essayé cette fomule, mais celà ne marche pas:
=si(a<x<y;x;a) en fait ce qu il ne fonctionne pas c est les deux:
exemple: x=5
=si(2<5<7;5;2) le resultat normal devrait etre vrai et resultat serait 5 mais non cela me mets faux et reponse 2
merci de votre aide
pamyr44

Nouveau membre
Inscrit le: 14 Fév 06
Messages: 3

MessagePosté le: 29 Déc 2011 19:46 
Bonjour

Excel ne sait pas traiter la formule comme vous l'avez écrite
Il faut décortiquer la condition, et lui dire :

=SI(ET(B3>B4;B3<B5);B3;"FAUX")

avec X en B3, A en B4, B en B5

et ça marche !

Par rapport aux bornes, si vous ne voulez pas d'inégalités strictes, vous avez le droit d'utiliser les opérateurs >= et/ou <=

Pamyr44
Montrer les messages depuis:   
Poster un nouveau sujetRépondre au sujet    Savoirtoutfaire Index du Forum -> Bureautique Toutes les heures sont au format GMT + 2 Heures
Page 1 sur 1




 

Sujets similaires du


Pourquoi ne pas profiter de code promo sur la bureautique ?
Comment et avec quoi creer un fichier interactif ?
Comment créer une Liste ou menu déroulant avec Excel ?
Comment créer une icône ?
Comment créer une nouvelle police ?
Comment créer un inventaire de mes timbres ?
Comment créer un raccourci bureau ?
Comment créer un nouveau fichier ?
Comment créer u_n thème de bureau pour un XP ?
Comment créer un formulaire sous Excel ?
Comment créer un abécédaire en A4 recto-verso ?
Comment peut-on créer des badges sur Word ?
Comment créer une base access+lecteur de carte magnétique ?
Comment créer un réseau entre deux ordinateurs sous vista ?
Comment créer une image GIF animé et modifier une image ?

Liens Google


Mots clés :

maison plancher panneau hauteur condensateur côté courant face sol bureau volts multimètre niveau travaux base bois surface longueur fichier clic tension taille page fixer plafond droite mur fil poutres gauche poser pièce borne travail ligne spots valeur point coller vieille résistance réaliser traitement facile position calculer puissance choisir risque ohms
Administratif et JuridiqueAdministratif et Juridique ApicultureApiculture AutomobileAutomobile BeautéBeauté BonsaïBonsaï CoutureCouture CuisineCuisine DécorationDécoration ÉconomiesÉconomies ÉlectricitéÉlectricité ÉlectroménagerÉlectroménager ÉlectroniqueÉlectronique FleursFleurs InternetInternet MaçonnerieMaçonnerie ModélismeModélisme NettoyageNettoyage OrigamiOrigami PhotoPhoto PlomberiePlomberie PotagerPotager SantéSanté SolfègeSolfège Travail du boisTravail du bois TricotTricot VidéoVidéo